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MapZone

MapZone is a procedural texture generator that can be used to create high-quality,
seamlessly tiling textures. These textures are output as bitmaps which can then be converted
in the image editing program of your choice to whatever format you need for your own
projects. This tutorial will get you started with MappZone, but it is only the tip of the
iceberg; the possibilities really are nearly limitless.

Installing MapZone

Download MapZone, the editor is free to use, and all of the textures you generate with it can
be used and distributed freely in your own projects. MapZone also comes in a pro edition
called ProFX which can be used to procedurally generate textures on the fly. Generating
textures procedurally means you don't have to distribute hundreds or thousands of textures
with your games and can save tremendously on disc space and download sizes. ProFX will not
be covered in this tutorial.

Operating System: This tutorial covers the Windows version of MapZone, and was originally
written on a Windows XP system, and later a Windows 7 system. If you are using a different
setup, there may be some discrepancies.

Starting a New Project

Once you have MapZone downloaded and installed, double-click on the icon to open it.

In order to create a new texture file (or map, to use MapZone parlance), double-click on the
'New' folder. When the folder opens, you will see a 'New' file icon like the one shown in the
screenshot above. To start working on your map, double-click the new file, or map. This will
open the map editor.

User Interface

MapZone's interface is very daunting for many people the first time they see it, but it becomes
quite intuitive and enjoyable once you have acquired a little experience with it. This section
will provide you with a quick overview of the interface (which you can refer to later as a
reference if you need to), but don't worry about trying to remember all of this now; every
element of the interface will be touched on later on in the tutorial.

Tooltips: Although MapZone is considered by many to have a very steep learning curve, it is
very, very good at documenting itself through tooltips. I've learned as much by reading the
tooltips as I have through traditional tutorials so if you ever get stuck on something make sure
you pay attention to the feedback the editor is giving you.

MapZone's interface is divided into several windows, many of which are hidden by default but
which can easily be accessed by the use of sliding tabs. When you first open MapZone, you are
presented with three main windows, a menu bar, and a status bar at the bottom of the
screen.

1. The menu bar contains standard GUI features and roundabout ways of interacting with the
interface. The File menu contains common file operations like 'New', 'Save', 'Open', etc. The
Graph menu provides options for adding FX-Maps and Filters. The Node menu contains
commands for performing various operations on nodes. The View menu provides various
options for showing, hiding, docking and undocking panels. The Undo button allows you to
undo your previous action (though I have not tested it to see how many undos are allowed).
The Help button opens the MapZone documentation page on the Allegorithmic web site. The
little question mark button can be used to gather additional information about the interface
by clicking on it and then clicking on the item of interest.

2. The first panel, in the upper left corner of the interface, is the Presets viewer. Presets are
pregenerated texture patterns which you use as the basis of your own textures. MapZone
comes with quite a few presets, all of which can be customized to some extent through the
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editor, and you can add your own if you can't find what you're looking for. To see the list of
presets available, just scroll through them with your mouse wheel or by grabbing the
scrollbar.

3. The second panel, to the right of the Preset viewer, is the Compositing Graph, or node
viewer. This panel shows you a graph chart of the various nodes that make up your map. A
node, in MapZone, is essentially a component of your map: a preset, filter, or other operation
being performed on your map. Nodes may be moved around and connected to and
disconnected from other nodes to achieve exactly the kind of effect you're looking for. (If you
are familiar with image editing programs like PhotoShop or The Gimp, you can think of nodes
as layers.) Although it seems strange at first, once you get used to it, you will find the
Compositing Graph a very easy and efficient way of working with textures.

4. The third panel, which takes up the large area at the bottom of the interface, is the 2D
viewer. This panel shows you a preview of the texture represented by the currently selected
node in the Compositing Graph.

5. The status bar at the bottom of the interface shows you your progress on executing the
current action.

In addition to these default screen widgets are a number of hidden ones which are accessible
via sliding tabs or through the View menu.

6. The first of these is the 3D viewer ('3D Edit') which is visible as a sliding tab at the far left
of the 2D viewer. You can open and close this tab by clicking the little arrow at the top of the
tab. The 3D viewer allows you to see how your texture looks after being mapped to a 3d
object. A number of different default objects are available for previewing, and it is possible
to import your own models in 3ds and ASE formats (3ds Max/Autodesk formats). The 3D viewer
also contains a light source which you can manipulate to see how your texture looks when lit.

7. With the 3D viewer open, you will see another sliding tab called 'FX Shader'. To open it,
click on the little arrow. This panel allows you to edit various shader parameters, allowing
you even more control over your final map. This is an advanced topic which will be covered
later in the tutorial.

8. A similarly unobtrusive panel can be found at the far right of the Compositing Graph in the
upper right corner of the interface. This panel, the Fx-Map editor allows you to edit the FX-
Maps in the Compositing Graph, or even create entirely new ones. This is another advanced
topic which must wait for a later part of the tutorial.

9. When you add a filter to the node graph, you can edit it via the Filter editor. To open the
Filter editor, double-click on a filter node. The effects of editing a filter depend on the type
of filter being used. We will cover filters in greater depth a little later in the tutorial.

Now that you've been introduced to the interface, let's create a simple map to test it out.

Adding a Uniform Color Filter

For our first project, we are going to create a simple texture with a uniform color and export
it as a bitmap. Start a new project, either by opening MapZone and selecting New from the
Library dialog (if you don't currently have the program running), or by selecting File->New
from the menu bar or by using the Ctrl+N keyboard shortcut (if you do).

Place your mouse cursor over the Compositing Graph (the window in the top right) and right-
click. This should pull up a context menu like the one in the image below:

From the menu, slide over to New Filter->Uniform Color. Select it by left-clicking. This will
add a new node to the Compositing Graph wherever you right-clicked your mouse. (You can
move the node around by left-clicking on it and dragging it. The cursor should turn into a
little four-way arrow.) Double-click your new node to view it in the 2D viewer in the bottom
window. You should have a nice black square like the one below:



Changing the Filter's Color

Black is pretty boring, so we're going to change the color now by using the Filter editor. The
Filter editor is conveniently located in the middle of the screen between the Compositing
Graph and the 2D viewer where it says 'Filter Type:' followed by a tab for our selected filter.
To open the Filter editor, left-click on the color swatch in the middle (which is black, like our
texture).

This will pull up MapZone's color editor, which should look pretty familiar to anyone who has
used a Window's graphics program before.

The Pick Color dialog provides you with various ways to select a color, but the easiest and
most intuitive way is to use the color wheel and triangle widget in the middle. To choose a
color, grab the little circles or rings by pressing and holding the left mouse button and drag
them around the widget. When you have the color you want, release the mouse button and
the texture's color will automatically update. If you decide you don't like the color, you can
click the Cancel button to close the color editor and restore the texture's previous color. If
you are happy with it, just click the Close button. (Note that the red 'x' button at the top of
the window works like the Close button and will update your texture with the new color. If
you pressed this button and meant to cancel instead, just press the Undo button on the menu
bar to undo the last change.)

The screenshot shows an example color:

Additional Notes for People Who Have Never Used a Color Picker: The ring on the color wheel
controls the hue, or color; the ring on the triangle controls the lightness and saturation. If you



drag the ring on the color wheel without adjusting the ring on the triangle, you may notice
that your texture isn't changing color; that's because your lightness is set at 100% dark. To see
any color change, you have to drag the ring on the triangle away from the black corner. If you
drag the ring along the left side of the triangle, you will only see shades of grey, no matter
what color you have selected from the color wheel. That's because you have your saturation
set to 0%. To see some color, you need to drag the ring on the triangle toward the colored
point. Using this tool, you can literally pick from millions of colors, so have fun!

Adding an Output Node

Now that we have a simple texture, we need some way to get it out of MapZone. To do this,
we need to add an output node to the Compositing Graph. Right-click in the Compositing
Graph and select New Filter->New OUTPUT (at the bottom of the menu). This will pop up a
small dialog window with a drop down menu. You can give your output node any name you
like, but in this case, it's fine to just leave it at the default 'diffuse' (ie. color) and press OK.

Now we have an output node, but we need to tell MapZone what to output. To do this, we
need to connect our input node (the Uniform Color node) to the output node (Output diffuse
node). To do this, place your mouse cursor over the filter output connector, or pin, (the little
left-pointing triangle, or arrow) on the Uniform Color node. It should highlight with an orange
border and pop up a tooltip like in the image below:

Press and hold the left mouse button and drag the little line toward the Output diffuse node.
The line will remain red until it finds an input connector/pin it can connect to.

Place your mouse cursor over the input pin (the little triangle) on the Output diffuse node.
The line should turn orange to indicate that it is in position to connect to the node.

Release the left mouse button. The line should now turn yellow to indicate that you have
made the connection.

This is how you connect all of the nodes in MapZone, although some nodes have a different
number of input and output pins and can only be combined in certain ways.

Disconnecting Nodes: To disconnect a node from another node, right-click the input pin on
the node that you want to disconnect from and choose 'Disconnect'. You can also disconnect
nodes by holding down the Shift key and dragging with the right mouse button. This is a handy



way to disconnect multiple nodes at the same time. You can also select the input pin on the
node you want to disconnect from with the left mouse button and drag the connector to a
different node. This is a good way to switch between nodes to compare how they look.

Exporting the Bitmap

Now we have our input node connected to our output node so all we have to do to create the
texture is right-click the Output diffuse node and select 'Export bitmap...' from the menu.
This pulls up the file explorer dialog which comes with nearly every Windows program in
existence and which you should already be familiar with. Pick a destination folder for your
new texture, give it a name and click Save. (If you're not sure where to save your file, you
can always save it to your desktop. That way you know you can find it. And you can always
move it later.)

Here is a screenshot of my new texture in The Gimp (a popular open source image editor):

Saving Your New Map

If you want to save your new texture (or map, to use MapZone parlance), select File->Save As
or press Ctrl+Shift+S. This pulls up the little save file widget shown in the image below:

Type the name of your new map in the text field where it says 'New' beside 'Title:'. You can
select a different folder to save your map to by clicking on the button beside 'Library Folder:'
(in this example, the name of the folder you are saving to is 'New', which is MapZone's default
folder for new maps). This will open the Library dialog window. From here you can select a
different folder to save to by selecting it with the left-mouse button and clicking 'Ok' from
the menu bar at the top right of the window. (Tip: If you want, you can also create a new



folder by right-clicking beside another folder in the left half of the Library dialog window and
selecting 'New folder' from the context menu. This will create a new folder inside the folder
that you clicked beside.)

Save File Widget: Note that, although the save file widget doesn't look like a normal window,
it behaves like one. As long as the widget is open, you won't be able to interact with the
MapZone editor. Either save your file or cancel the save to close it and keep working.

When you save a map file (which has a .map extension), you're not saving a bitmap image, like
the one that you see when you export your texture; you're saving all of the node information
from the Compositing Graph, the instructions that tell MapZone how to recreate your texture
the next time it opens it. By uploading your .map file to the web, you can share your new map
with the MapZone community so that others can see how you created your awesome effects,
or get help troubleshooting your maps when you run into problems.

Conclusion

A uniform color texture may not be much to look at, but this simple example demonstrates
many of the basic principles of using the Compositing Graph and exporting bitmaps in
MapZone. As you can see, the Compositing Graph is essentially a flowchart showing how all of
the different elements of your texture fit together to create the final image. Later examples
will be more complex, but this quick overview should give you a pretty good idea how things
work in MapZone. 
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